Description

Firebase integration for Gamemaker Studio (Android)! Currently supports:

  • Full analytics integration
  • Full remote configuration integration

More requested features may follow soon based on the amount of support the asset gets.

Please use the contact link if you need technical support implementing the extension.

Please note: This extension requires some initial setup, check the following link for instructions.

Documentation & Integration Guide

Need an Android extension or SDK Implementation?

MORE ASSETS

GMLVideo

End User Licence Agreement (EULA).

Version 0.1.0. Published November 14, 2016

Created with GameMaker: Studio v1.99.505

Age Rating: 4+

Average Rating

Your review

You can only review assets you've bought.


Gravatar

Anonymous 28 December 2018

It not working for me

This extension cannot work for me with game Maker Studio 2 and the actual version of firebase!
i cannot hable to compile my game with all modifications.


Gravatar

Petri B 05 October 2017

It works with a little help from Taylor

At first I had difficulties to get the firebase-extension work with the GooglePlayServices-extension (yoyogames).
The publisher was very helpful and gave me an advice:
- to just double-click GooglePlayServices and select Android tab
- go to "inject to Gradle Dependencies" search and replace all "9.6.1" with *9.8.0"

Logo

Taylor Dale (Publisher) 07 January 2018

Hi Pete,
Glad we were able to sort that one out. To people trying to do the same, I would recommend first trying the integration without making these changes, and if it fails to compile contact me as the advice may change from time to time.


Gravatar

Kyle S 20 April 2017

Good Extension

Works great. Would like to see some updates though.


Gravatar

Andrej P 04 April 2017


Gravatar

Seonmin L 28 December 2016

[SOLVED] It's failed. :(

Hi, I just used 'GooglePlayServicesExtension', 'GooglePlayServicesIAPExtension' and your 'Firebase'.
But, I got some errors.

Like this)))
* What went wrong:
Execution failed for task ':com.ctstrp.stlt:transformClassesWithJarMergingForRelease'.
> com.android.build.api.transform.TransformException: java.util.zip.ZipException: duplicate entry: com/google/android/gms/internal/zzsm.class

Give me the SOLUTION plz!

-------------------------------ADDED---------------------------------

I modified Gradle dependencies of 'GooglePlayServicesExtension'. (up to 10.0.1 along with yours)
And I solved problem.
THANK U for nice extension!

Logo

Taylor Dale (Publisher) 28 December 2016

Hi there, this could be due to conflicts with how YYG have developed their extension. Please make sure you've followed the included instructions to implement it and if it is still not working contact me with the link above :)


Gravatar

Hunter C 04 December 2016

Great Product... But

Please add firebase realtime database and I will give you 5 stars :)


Gravatar

Anonymous 14 November 2016

just testing it out looks good


Gravatar

Anonymous 14 November 2016

Good


Gravatar

Anonymous 14 November 2016

finally!!!

The integration takes a minute but other than that perfect!

Logo

Taylor Dale (Publisher) 14 November 2016

Cheers! Will be adding an automatic process for integration in the future.

Package contents

Loading, please wait

What is the issue?

Back to Top